Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 50

Thread: VRipper X (MacOS / Linux) Download Images 

  1. #16
    Member stanna's Avatar
    Joined
    24 Jun 2013
    Location
    beer.au 
    Posts
    46
    Images
    42
    Thanked
    25

    Re: VRipper X (MacOS / Linux)

    other than the odd javascript error message on exit i have no problem with this in Arch linux on my laptop. somewhat lacking in features like its Windows brother but im sure the new version will fill the gap nicely. Thanks Isana!

  2. #17
    Member
    Joined
    24 Apr 2014
    Posts
    7
    Images
    0
    Thanked
    8

    Re: VRipper X (MacOS / Linux)

    I'm a little confused on the 32-bit Linux version (vripperx-0.0.3-ia32.AppImage). Is that intended to work on 32-bit x86? Attempting to run any of the executables in that image gets me a "cannot execute binary file: Exec format error" here (on an old pentium 4). Thanks!

  3. #18
    Member
    Joined
    11 May 2015
    Posts
    16
    Images
    0
    Thanked
    4

    Re: VRipper X (MacOS / Linux)

    Uninstalling and reinstalling fixed it!

  4. #19
    Member
    Joined
    3 Nov 2016
    Posts
    6
    Images
    0
    Thanked
    4

    Re: VRipper X (MacOS / Linux)

    @dig989
    As I understand AppImage is not traditional executable, by its own. It is new format, so older distros doesn't support it as natively, like newer do. So you probably have to first add AppImage support, and yes, IA32 means it contains x86-32 code.

    Sadly, my Test machine runs with Ubuntu Desktop 17.02 64-bit and there it worked almost natively. So I can't help you with exact process, but I am sure Google will help.

  5. #20
    Member
    Joined
    24 Apr 2014
    Posts
    7
    Images
    0
    Thanked
    8

    Re: VRipper X (MacOS / Linux)

    Quote Originally Posted by Mialur View Post
    @dig989
    As I understand AppImage is not traditional executable, by its own. It is new format, so older distros doesn't support it as natively, like newer do. So you probably have to first add AppImage support, and yes, IA32 means it contains x86-32 code.

    Sadly, my Test machine runs with Ubuntu Desktop 17.02 64-bit and there it worked almost natively. So I can't help you with exact process, but I am sure Google will help.
    That AppImage isn't an issue...that just a disk image. I was easily able to mount that on an empty directory using mount with the "-o loop" option. Doing that I can see the contents. It's just that the executable programs in there aren't an executable format recognized by my system. No real issue though. For now I've been running the windows vipperripper via wine successfully.

    Thanks!
    Tom

  6. #21
    Member
    Joined
    11 May 2015
    Posts
    16
    Images
    0
    Thanked
    4

    Re: VRipper X (MacOS / Linux)

    Quote Originally Posted by picarock View Post
    Uninstalling and reinstalling fixed it!
    Well, I'm getting red bars again from many different threads and recent posts. Uninstall/reinstall did not fix it this time.

    I'm also sometimes getting JS/electron error messages upon quitting the app, but I didn't think of taking a screenshot.

    Where are the Vripper X settings and history on MacOS? Can they be reset?

  7. #22
    Member
    Joined
    3 Nov 2016
    Posts
    6
    Images
    0
    Thanked
    4

    Re: VRipper X (MacOS / Linux)

    File with settings and history is in home directory, it is probably hidden file (dot at the beginning) ".VRipper X"

    Yes, you can reset it, but I have no mac to try, so I have to rely to others ─ I did found older reply from Isana. I Quoted required lines below, when you put them on command line, they should do the trick.

    Quote Originally Posted by Isana View Post
    rm ~/.VRipper\ X
    rm -r ~/.config/vripperx

  8. Thanked by 2 users: Isana, picarock

  9. #23
    Member
    Joined
    11 May 2015
    Posts
    16
    Images
    0
    Thanked
    4

    Re: VRipper X (MacOS / Linux)

    Thanks, deleting .vripperX fixed it. I didn't see a .config/vripperx. Anyhow, Thanks @Mialur!

  10. #24
    Member Isana's Avatar
    Joined
    27 Jan 2015
    Posts
    30
    Images
    3
    Thanked
    63

    Re: VRipper X (MacOS / Linux)

    Haven't had much free time this past week, but I will likely be pushing out at least one more update for VRipper X before I have the new Viper Ripper ready.
    Mostly maintenance updates, but there will be some new additions as well.

    Quote Originally Posted by dig989 View Post
    That AppImage isn't an issue...that just a disk image. I was easily able to mount that on an empty directory using mount with the "-o loop" option. Doing that I can see the contents. It's just that the executable programs in there aren't an executable format recognized by my system. No real issue though. For now I've been running the windows vipperripper via wine successfully.

    Thanks!
    Tom
    That's strange. The AppImage should also be executable and the contents of the AppImage should work even if you were to extract them. Mind telling me which distribution you're running? I haven't had the chance to test on a 32-bit machine or virtual machine, so perhaps something is breaking related to that. I'll perform my own tests soon and see if I can reproduce your issue. Apologies for the inconvenience!
    Last edited by Isana; 17th June 2017 at 03:37.

  11. #25
    Member thatatkguy's Avatar
    Joined
    19 Apr 2017
    Posts
    11
    Images
    0
    Thanked
    2

    Re: VRipper X (MacOS / Linux)

    Hi, first of all thank you for the work for brining VRipper back!

    I have encountered a problem with some threads, such as this one: https://vipergirls.to/threads/206472...px-(30-08-2016)
    No image gets downloaded and I get an error: bad status code: 301 moved permanently.

    Any idea what might be the problem? Thank you!

  12. #26
    Member Isana's Avatar
    Joined
    27 Jan 2015
    Posts
    30
    Images
    3
    Thanked
    63

    Re: VRipper X (MacOS / Linux)

    Quote Originally Posted by thatatkguy View Post
    Hi, first of all thank you for the work for brining VRipper back!

    I have encountered a problem with some threads, such as this one: https://vipergirls.to/threads/206472...px-(30-08-2016)
    No image gets downloaded and I get an error: bad status code: 301 moved permanently.

    Any idea what might be the problem? Thank you!
    Those images are hosted on a banned host, so I didn't test anything hosted there. Since it has been brought up though, I'll get this working in the next update.

  13. #27
    Member
    Joined
    3 Nov 2016
    Posts
    6
    Images
    0
    Thanked
    4

    Re: VRipper X (MacOS / Linux)

    Quote Originally Posted by thatatkguy View Post
    Hi, first of all thank you for the work for brining VRipper back!

    I have encountered a problem with some threads, such as this one: https://vipergirls.to/threads/206472...px-(30-08-2016)
    No image gets downloaded and I get an error: bad status code: 301 moved permanently.

    Any idea what might be the problem? Thank you!
    Problem with this thread is, chronos seems to direct https requests to https://vipergirls.to/threads/1498244 address.

  14. #28
    Member
    Joined
    3 Nov 2016
    Posts
    6
    Images
    0
    Thanked
    4

    Re: VRipper X (MacOS / Linux) - AppImage

    Quote Originally Posted by Isana View Post
    Quote Originally Posted by dig989 View Post
    That AppImage isn't an issue...that just a disk image. I was easily able to mount that on an empty directory using mount with the "-o loop" option. Doing that I can see the contents. It's just that the executable programs in there aren't an executable format recognized by my system. No real issue though. For now I've been running the windows vipperripper via wine successfully.

    Thanks!
    Tom
    That's strange. The AppImage should also be executable and the contents of the AppImage should work even if you were to extract them. Mind telling me which distribution you're running? I haven't had the chance to test on a 32-bit machine or virtual machine, so perhaps something is breaking related to that. I'll perform my own tests soon and see if I can reproduce your issue. Apologies for the inconvenience!
    Technically AppImage is .iso file, so it is mountable. But extracted executable probably aren't directly executable. For running AppImage, you may be interested installing AppRun and even appimaged daemon.

    Short description for this format you can find on link

  15. #29
    Member Isana's Avatar
    Joined
    27 Jan 2015
    Posts
    30
    Images
    3
    Thanked
    63

    Re: VRipper X (MacOS / Linux)

    Quote Originally Posted by Mialur View Post
    Problem with this thread is, chronos seems to direct https requests to https://vipergirls.to/threads/1498244 address.

    Simple fix. Since VRipper was switched to HTTPS as the default protocol, I just opted to explicitly define the hosts that do not support HTTPS in favor of always using HTTPS whenever it's supported. I may just update this to test both protocols before actually starting the task and removing the need to explicitly define those that don't support HTTPS, but it hasn't caused too many issues so far.

    Also, as for AppImage, I'm aware that it's essentially a disk image with an executable embedded in the header which executes one of the contained files which, in turn, runs the actual application, but it's recognized as an executable file.


    All of the application's files are in the /usr/bin directory inside the AppImage and can be extracted and run just as if it were distributed in a standard archive as a portable application. I'll see if I can determine why it's not working correctly for them.
    If you should need to get in contact with me for some reason, you can find me on Wire: @isana

  16. #30
    Elite Prospect Ork666's Avatar
    Joined
    27 Sep 2012
    Location
    Central Europe 
    Posts
    1,079
    Images
    142,064
    Thanked
    10,448

    Re: VRipper X (MacOS / Linux)

    VRipper X not working for acidimg.cc, this thread https://vipergirls.to/threads/287076...light=lady+dee please fix it.
    Euro Girls Lover


Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions